import Foundation
let pattern = #",?\+\d+_[^,]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"+1223,+12_remove_me,+222,+2223_remove_me"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)