$re = '/http:\/\/(.*?).flv/';
$str = 'http://www.somesite.com/ac.flv';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);