#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^([a-z][\w-]{0,255}\.)*([a-z][\w-]{2,255}\.)(gov|edu|mil)(\.[a-z]{2})?$"
Local $sString = "b2.a1.a21.edu.tr"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")