import Foundation
let pattern = #"^([a-z][\w-]{0,255}\.)*([a-z][\w-]{2,255}\.)(gov|edu|mil)(\.[a-z]{2})?$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"b2.a1.a21.edu.tr"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}