using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\h*\/\/.*$";
string input = @"wolf
// testcattle
sheep
deer
// man
// help
//:google.com
http://www.google.com
src= "" //:google.com""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}