using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?sm)interface (\S*)(?:(?!^!$).)*port-security.*?!$";
string input = @"interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 10.0.0.1 255.2555.255.0
no ip route-cache
!
interface Vlan20
no ip address
!
interface GigabitEthernet1/0/5
description PC-05
switchport access vlan 20
switchport mode access
switchport nonegotiate
shutdown
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet1/0/6
description PC-06
switchport access vlan 10
switchport mode access
switchport nonegotiate
switchport port-security maximum 2
switchport port-security aging time 2
switchport port-security violation restrict
switchport port-security mac-address aaaa.aaaa.aaaa vlan access
switchport port-security mac-address bbbb.bbbb.bbbb vlan access
spanning-tree portfast
spanning-tree bpduguard enable
!
end";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}