$re = '/([^ =\[\]]+)(?:\[(\d+)\](?:\[(\w)\])?)?(?:=((?:".*?")|(?:[^ ]+)))?/';
$str = 'foo.csv foo=bar bang="this is a test" filter[1]="molf" filter[2][r]="gnarf dd"
http://bla.com/foo.png foo=bar bang="this is a test" filter[1]="molf" filter[2][r]="gnarf dd"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);