# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\s(SOCIEDAD ANONIMA|LIMITADA|L.?T.?D.?A.?|E.?I.?R.?L.?|S.?P.?A.?)|(LIMIT[DA]*?)|(S[\.\s]{0,2}?A\.?)$"
test_str = ("SERVICIOS MARITIMOS LITORAL LIMITADA\n"
"GINO ALBERTO GATTINI COLLAO\n"
"DORA SUSY TAPIA SANTOS\n"
"MARIA VERONICA CORDOVA CARBONELL\n"
"JEREMY ADRIAN BURFORD BEER\n"
"SOC DE INVERSIONES GUINGUIS Y JADAD LTDA\n"
"DIGNA ISABEL RETAMAL ARAYA\n"
"EVELYN JOHANNA PEREIRA HENRIQUEZ\n"
"MANUFACTURAS TEXTILES COLETT INTERNACIONAL LIMITADA\n"
"NATALIA CAROLINA ESPINA TEILLIER\n"
"INVERSIONES COP DE ROC LIMITADA\n"
"AGRICOLA LA RINCONADA DE CALERA DE TANGO LIMITADA\n"
"BOSTON SCIENTIFIC LATIN AMERICA B V CHILE LIMITADA\n"
"COMERCIALIZADORA PRODUCTOS DEL NORTE Y SERVICIOS LTDA\n"
"LATITUD 90 S A\n"
"s.a.\n"
"s.a\n"
" sa\n"
" s.a.\n"
"sa.\n"
"S. A.\n"
"COMERCIAL DICU LIMITADA\n"
"MARIO DEL VILLAR ESCUTI Y CIA LTDA\n"
"AGRICOLA Y FORESTAL LAS BANDURRIAS LIMITADA\n"
"CHIRINO Y ASOCIADOS,AUDITORES CONSULTORES LIMITADA\n"
"VICHERAT Y PRADENAS LIMITADA\n"
"ASESORIAS E INMOBILIARIA FROIMOVICH LIMITADA\n"
"KENTUCKY FOODS CHILE LTDA\n"
"EPREL LIMITADA INGENIERIA Y CONSTRUCCION\n"
"PLASTICOS ARAUCO LIMITADA\n"
"INVERSIONES Y CALZADOS GRECO LIMITADA\n"
"PESQUERA OMEGA LIMITADA\n"
"PERFORACIONES AUSDRILL (CHILE) LTDA\n"
"KINTETSU WORLD EXPRESS (CHILE) LIMITADA\n"
"SOC PESQUERA QUEHUI S. A.\n"
"DORA SUSY TAPIA SANTOSsat\n"
"TALLERES LUCAS ATACAMA LIMITADA\n"
"AUTOMOTRIZ QUELLE LIMITADA\n"
"ERRAZURIZ Y BUSTAMANTE LTDA\n"
"MARVELKLEEN SOCIEDAD ANONIMA\n"
"BODEGAJE Y ALMACENAJE LIMITADA\n"
"SODEXO INVERSIONES S A\n"
"COMERCIALIZADORA DE ARTICULOS DE ORTOPEDIA Y TRAUMATOLOGIA\n"
"TAYLOR Y MONTGOMERY S A")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.