using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(__|--)((?:(?!\1).)+)\1";
string input = @"__word1__ not_italic __a__ --bolder--
this is an __italic part of the sentence_with underscores__";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}