$re = '/(__|--)((?:(?!\1).)+)\1/';
$str = '__word1__ not_italic __a__ --bolder--
this is an __italic part of the sentence_with underscores__';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);