$re = '/\'\'|(\')/';
$str = 'You\'re Doing It Wrong!!,\'\'\'Mike Walsh\'\',Intermediate';
$subst = "''";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;