# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^ *funcA *\(([^,\s;)]*) *(?:, *([^)\;]+))?/if(isTrue) funcB($1, funcC($2)/gm;t' <<< "funcA(param0,param1,param2,param3);
funcA(param0,param1,param2,param3, param4);
funcA(param0, param1);
funcA(param0);
funcA(param0,param1,param2,param3);
"