use strict;
my $str = 'funcA(param0,param1,param2,param3);
funcA(param0,param1,param2,param3, param4);
funcA(param0, param1);
funcA(param0);
funcA(param0,param1,param2,param3);
';
my $regex = qr/^ *funcA *\(([^,\s;)]*) *(?:, *([^)\;]+))?/mp;
my $subst = 'if(isTrue) funcB($1, funcC($2)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";