use strict;
my $str = 'This is aa
This is aa test
aa aa aa aa aa aa aa
This should m\'atch
This a-lso\'
This is a test
a b
aa
a
This is aa test
This\' is aa tes
This is aaaa longer test
This sh\'o\'uld not
This sh-o-uld not
';
my $regex = qr/^[a-zA-Z](?!.*(['-]).*\1)(?!.* )(?=.{0,19}$)[a-zA-Z0-9'-]*(?: (?<=[a-zA-Z] )[a-zA-Z][a-zA-Z0-9'-]*)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}