const regex = /(?<!https?:\/\/\S*)\bbitcoin.*?[\\s.,?!]/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!https?:\\\/\\\/\\S*)\\bbitcoin.*?[\\\\s.,?!]', 'gmi')
const str = `Bitcoin price is going nuts", it would find it, but it was also take the following url and match it. https://versionone.vc/the-solar-bitcoin-convergence, messing up the url.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}