$re = '/^[A-Za-z0-9]{15}(?:[A-Za-z0-9]{3})?$/mi';
$str = '001i000001AWbWuGTA
001i000001AWbWugta
50130000000014c
50130000000014C
50130000000014ca
50130000000014cab
50130000000014cabde';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);