import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\*\\*(?<bold>(?:(?!\\*\\*).)+)\\*\\*|`(?<code>[^`]+)`|~~(?<strike>(?:(?!~~).)+)~~|\\[(?<linkTitle>[^]]+)]\\((?<linkHref>.*)\\)|(?<normal>[^`[*~]+)|\\*(?<italic>[^*]+)\\*|(?<tara>[*~]{3,})|(?<sitara>[`[]+)";
final String string = "some normal and **bold with * gem*** but pure *italics* is alos there baby now ~~coming~~hola amigons~~strike~~ wooo lala what about blazing *********here baby ~~~~~~~~~baby `baby```[[[[[[[[[[[[[[[l]]]]int](href)[link](href)``````````";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}