$re = '/(?m)(?:([a-zA-Z])(?!\1)|^)(([a-zA-Z])\3)(?!\3)/';
$str = 'assfdbfool
laaate
deeeeell
tjjr
pp';
$subst = "$1$2$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;