// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<li>(.*)").unwrap();
let string = "<li>some text
some text";
let substitution = "<li>$1</li>";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}