package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\{{([\w\.]+)(?:\s+(\w+)=(?:("(?:[^"]*)")|([\w\.]+)))*\}\}`)
var str = `{{token arg=1 id=2 class=3}}`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}