# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<)(br|div)([^>]+?)(\\/?\s*>)/\1\2\4/gmi;t' <<< "<br id=\"foo\" style=\"display:none\">
<spam id=\"bar\">sometext</span>
<br id=\"bun\" />
<div class=\"foo\">
<div class=\"bar\">
<a href=\"baz.php\">baz</a>
</div>
</div>"