const regex = /(<)(br|div)([^>]+?)(\/?\s*>)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<)(br|div)([^>]+?)(\\\/?\\s*>)', 'gmi')
const str = `<br id="foo" style="display:none">
<spam id="bar">sometext</span>
<br id="bun" />
<div class="foo">
<div class="bar">
<a href="baz.php">baz</a>
</div>
</div>`;
const subst = `\1\2\4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);