$re = '/.*(?!arm)\.dts$/m';
$str = './arch/arm64/boot/dts/ttt.dts
./arch/h8300/doot/dts/ttt.dts';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);