re = /@e(?:[^u]reka|u[^r]eka|ur[^e]ka|ure[^k]a|urek[^a]|eurk[^a])\.com/m
str = 'jcarter@euneka.com
jcarter@eurrka.com
jcarter@eur4ka.com
jcarter@eur3ka.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end