package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\d{1,2}$|(100)`)
var str = `0.00`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}