use strict;
my $str = 'data212.data';
my $regex = qr/\..+[a-z]/p;
my $subst = '. data';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";