$re = '/\d\h*-\h*(*SKIP)(*F)|-(?!\h*\d)/';
$str = 'Al-Abbas - Manama - 100
100 - foo';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;