re = /\b[\s(.)\d-]{6,}\d\b/
str = 'hola me llamo juana mi número es el 692147849 tengo otro número 692 14 15 16 y tengo otro más el 692.123.123
y el otro número es el 968 23 43 45 fasdf y el núḿero 968 123 123 y si ahora pongo http://www.laweb.es/12/24/323/323/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end