# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"_(A[PM]|EM)-"
test_str = ("t_name = [\n"
" \"XXX_Guangzhou_AP-CN-BEI-7517\",\"XXX_Jakarta_AP-ID-JAK-0001\",\"XXX_TaiPei_AP-TW-TPE-0002\",\n"
" \"XXX_Dubai_EM-AE-DUB-1012\",\"XXX_Viladecans_EM-ES-VIL-1002\",\"XXX_Ringsted_EM-DK-RIN-0001\",\n"
" \"XXX_Bogota_AM-CO-BOG-1033\",\"XXX_Hamburg_EM-DE-HAM-1004\", \"XXX_Bangkok_TH127\",\"XXX_Bangkok_TH124")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.