using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bMACHINE:\s*([^<]*(?:(?:\r\n?|\n)\S+)?)";
string input = @"MACHINE: p1prog06<br>
MACHINE: p1prog06";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}