#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "/^([a-z0-9]+(?:,[a-z0-9]+)*)$/gm"
Local $sString = "khjh,sdsds,sdsdsd,22222,22222;@@@;222-2-222;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")