using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/^([a-z0-9]+(?:,[a-z0-9]+)*)$/gm";
string input = @"khjh,sdsds,sdsdsd,22222,22222;@@@;222-2-222;";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}