use strict;
my $str = 'khjh,sdsds,sdsdsd,22222,22222;@@@;222-2-222;';
my $regex = qr//^([a-z0-9]+(?:,[a-z0-9]+)*)$/gm/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}