// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"/^([a-z0-9]+(?:,[a-z0-9]+)*)$/gm").unwrap();
let string = "khjh,sdsds,sdsdsd,22222,22222;@@@;222-2-222;";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}