use strict;
my $str = '------
Текст1
Текст2
....
Текстn
------';
my $regex = qr/Текст1(?s:.*?)Текстn/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";