re = /Текст1(?s:.*?)Текстn/
str = '------
Текст1
Текст2
....
Текстn
------'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result