$re = '/(0?[1-9]|1[0-2])\/(?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)\/(1|2)[0-9]{3}\s((0|1)[0-9]|2[0-3]):([0-5][0-9]):([0-5][0-9])/';
$str = '58.189.130.8 NULL-AUTH-USER 1/Jul/2013 03:27:12.818 +0900 GET /newnsmw/webresources/org.nns.entity.tenant/7ab0105f74f0cadbb20ddef606865b1c HTTP/1.1 200 2646
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);