$re = '/<a.+href=["\'](.*)["\'].*>(.*(?:test|aa).*)<\/a>/ismU';
$str = '<A href="rwrwerwe">rwewrtestewe</a> <a href=\'rwrwewre\'>wrewreaa2rwe</a> <a href="rwrwewre">notvalid</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);