re = /<a.+href=["'](.*)["'].*>(.*(?:test|aa).*)<\/a>/im
str = '<A href="rwrwerwe">rwewrtestewe</a> <a href=\'rwrwewre\'>wrewreaa2rwe</a> <a href="rwrwewre">notvalid</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end