$re = '/(\%\d*[ctYymd]+)|\$\d|([^$%]+)+/';
$str = '%03c_Ball0n%02c$1%03d_Ball0n%02d$1
%03c_Ball0n%02d-hansaBallon$1
%3c_Ball0n%2t%02d
%c_foo%Y-%m-%d-bardoo
Ball0n%02dHamburg%d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);