const regex = /((bool|byte|short|int|long|float|double|array|box)(\[((.*,)*.*)\])?) ([A-Za-z_][A-Za-z_0-9.]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((bool|byte|short|int|long|float|double|array|box)(\\[((.*,)*.*)\\])?) ([A-Za-z_][A-Za-z_0-9.]*)', 'gm')
const str = `box[int a, int b] c, bool f`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}