re = /(\w*)(\s+)(\d):(\d+)-?(\d*+)/m
str = 'John 1:3
Matthew 1:3-7
Matthew 1:13-17'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end