// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[ \t]+").unwrap();
let string = "database system,query optimization,semantic transformation basic operation crucial prerequisite fast implementation relational calculus representation wide variety database machine level query evaluation centralized database system alternative access plan generalized database management system processing unanticipated query query optimization issue heuristic algorithm distributed database general query evaluation procedure efficient method query evaluation algorithm ";
let substitution = " ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}