# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d+\S+\s+//g;t' <<< "canon 40 22mm lens lock strength plenty orientation 321 ."