import Foundation
let pattern = #"\d+\S+\s+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"canon 40 22mm lens lock strength plenty orientation 321 ."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)