package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\~(.*)\~|\^\((.*)\)`)
var str = `This is a ~text~ to test the results of substitution of ^(text2). This is how it gets`
var substitution = "<sub>\1\2</sub>"
fmt.Println(re.ReplaceAllString(str, substitution))
}