import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\~(.*)\\~|\\^\\((.*)\\)";
final String string = "This is a ~text~ to test the results of substitution of ^(text2). This is how it gets";
final String subst = "<sub>\\1\\2</sub>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}