use strict;
my $str = 'This is a ~text~ to test the results of substitution of ^(text2). This is how it gets';
my $regex = qr~\~(.*)\~|\^\((.*)\)~p;
my $subst = '<sub>\\1\\2</sub>';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";