// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\~(.*)\~|\^\((.*)\)").unwrap();
let string = "This is a ~text~ to test the results of substitution of ^(text2). This is how it gets";
let substitution = "<sub>\\1\\2</sub>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}