# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<li.*?>\s*(.*?)\s*</li>"
test_str = ("<li id=\"menu-item-98\" class=\"navigation-heading menu-item menu-item-type-custom menu-item-object-custom menu-item-98\">\n"
" <a href=\"#\">Main</a>\n"
"</li>")
subst = "<div class=\"navigation-heading\">\\n<span>\\n <span>\\1</span>\\n</span>\\n</div>"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.